baserCMS Cross-site Scripting Vulnerability in Favorites Feature
The advisory, in context
There is a XSS Vulnerability in Favorites Feature to baserCMS.
This is a vulnerability that needs to be addressed when the management system is used by an unspecified number of users. If you are eligible, please update to the new version as soon as possible.
Target
baserCMS 4.7.8 and earlier versions
Vulnerability
Malicious code could be executed in the Favorites feature on the server.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information. https://basercms.net/security/JVN_45547161
Credits
ota kyohei
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 4.8.0
Fixed in 4.8.0
112 explicitly affected versions
0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.0.6, 0.0.7, 0.0.8, 1.0.0, 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4, 2.0.0-rc5, 2.0.0-rc6, 3.0.10, 3.0.10.1, 3.0.11, 3.0.11.1, 3.0.12, 3.0.13, 3.0.14, 3.0.15, 3.0.16, 3.0.17, 3.0.18, 3.0.19, 3.0.20, 3.0.21, 3.0.22, 3.0.23, 3.0.24, 3.0.25, 3.0.26, 3.0.7, 3.0.7.1, 3.0.8, 3.0.8.1, 3.0.9, 3.0.9.1, 4.0.0, 4.0.0-beta, 4.0.1, 4.0.10, 4.0.10.1, 4.0.11, 4.0.2, 4.0.2.1, 4.0.3, 4.0.4, 4.0.5, 4.0.5.1, 4.0.5.2, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 4.1.0, 4.1.0.1, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.3.6, 4.3.7, 4.3.7.1, 4.4.0, 4.4.1, 4.4.1.1, 4.4.2, 4.4.2.1, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.5.0, 4.5.1, 4.5.2, 4.5.3, 4.5.4, 4.5.5, 4.5.6, 4.6.0, 4.6.1, 4.6.1.1, 4.6.2, 4.6.3, 4.7.0, 4.7.2, 4.7.3, 4.7.5, 4.7.6, 4.7.7, 4.7.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.8.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.0.1",
"0.0.2",
"0.0.3",
"0.0.4",
"0.0.5",
"0.0.6",
"0.0.7",
"0.0.8",
"1.0.0",
"2.0.0-rc1",
"2.0.0-rc2",
"2.0.0-rc3",
"2.0.0-rc4",
"2.0.0-rc5",
"2.0.0-rc6",
"3.0.10",
"3.0.10.1",
"3.0.11",
"3.0.11.1",
"3.0.12",
"3.0.13",
"3.0.14",
"3.0.15",
"3.0.16",
"3.0.17",
"3.0.18",
"3.0.19",
"3.0.20",
"3.0.21",
"3.0.22",
"3.0.23",
"3.0.24",
"3.0.25",
"3.0.26",
"3.0.7",
"3.0.7.1",
"3.0.8",
"3.0.8.1",
"3.0.9",
"3.0.9.1",
"4.0.0",
"4.0.0-beta",
"4.0.1",
"4.0.10",
"4.0.10.1",
"4.0.11",
"4.0.2",
"4.0.2.1",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5.1",
"4.0.5.2",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9",
"4.1.0",
"4.1.0.1",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.1.6",
"4.1.7",
"4.1.8",
"4.2.0",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.3.0",
"4.3.1",
"4.3.2",
"4.3.3",
"4.3.4",
"4.3.5",
"4.3.6",
"4.3.7",
"4.3.7.1",
"4.4.0",
"4.4.1",
"4.4.1.1",
"4.4.2",
"4.4.2.1",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.5.0",
"4.5.1",
"4.5.2",
"4.5.3",
"4.5.4",
"4.5.5",
"4.5.6",
"4.6.0",
"4.6.1",
"4.6.1.1",
"4.6.2",
"4.6.3",
"4.7.0",
"4.7.2",
"4.7.3",
"4.7.5",
"4.7.6",
"4.7.7",
"4.7.8"
]
}References
- https://github.com/baserproject/basercms/security/advisories/GHSA-8vqx-prq4-rqrq
- https://nvd.nist.gov/vuln/detail/CVE-2023-29009
- https://github.com/baserproject/basercms/commit/919c3ccbbd7a2432967dcb2e428131cc7ad71bb2
- https://basercms.net/security/JVN_45547161
- https://github.com/baserproject/basercms
- https://github.com/baserproject/basercms/releases/tag/basercms-4.8.0