GHSA-8r7r-f4gm-wcpqhigh8.1
Statamic affected by privilege escalation via stored cross-site scripting
Impact
Stored XSS vulnerability in html fieldtypes allow authenticated users with field management permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
statamic/cms Packagist
| Affected range | Recorded fix |
|---|---|
| From 6.0.0-alpha.1 before 6.3.2Ecosystem versions | 6.3.2 |
| Earlier releases before 5.73.9Ecosystem versions | 5.73.9 |
Version evidence: OSV · GHSA-8r7r-f4gm-wcpq
View original version evidence (518 explicit versions)
Original source description
Impact
Stored XSS vulnerability in html fieldtypes allow authenticated users with field management permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.
Patches
This has been fixed in 6.3.2 and 5.73.9.
References
- Security advisory github.com/statamic/cms/security/advisories/GHSA-8r7r-f4gm-wcpq
- Security advisory nvd.nist.gov/vuln/detail/CVE-2026-27196
- Patch github.com/statamic/cms/commit/11ae40e62edd3da044d37ebf264757a09cc2347b
- Patch github.com/statamic/cms/commit/6c270dacc2be02bfc2eee500766f3309f59d47b3
- Source reference github.com/statamic/cms