GHSA-8ppf-x4gr-2x7gcritical9.8
SQL injection in calibreweb
The advisory, in context
Calibre-Web before 0.6.18 allows user table SQL Injection.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
calibreweb PyPI
Ecosystem versions
Earlier releases before 0.6.18
Fixed in 0.6.18
6 explicitly affected versions
0.6.12, 0.6.13, 0.6.14, 0.6.15, 0.6.16, 0.6.17
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.6.18"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.6.12",
"0.6.13",
"0.6.14",
"0.6.15",
"0.6.16",
"0.6.17"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-30765
- https://github.com/janeczku/calibre-web
- https://github.com/janeczku/calibre-web/blob/master/SECURITY.md
- https://github.com/janeczku/calibre-web/releases/tag/0.6.18
- https://github.com/pypa/advisory-database/tree/main/vulns/calibreweb/PYSEC-2026-305.yaml
- https://pypi.org/project/calibreweb