GHSA-8mwx-wpp4-5xh4critical9.8
Magento Broken authentication and session managememt
The advisory, in context
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can append arbitrary session id that will not be invalidated by subsequent authentication.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
magento/community-edition Packagist
Ecosystem versions
From 2.2 before 2.2.10
Fixed in 2.2.10
10 explicitly affected versions
2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7, 2.2.8, 2.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2"
},
{
"fixed": "2.2.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.0",
"2.2.1",
"2.2.2",
"2.2.3",
"2.2.4",
"2.2.5",
"2.2.6",
"2.2.7",
"2.2.8",
"2.2.9"
]
}magento/community-edition Packagist
Ecosystem versions
From 2.3 before 2.3.2-p1
Fixed in 2.3.2-p1
3 explicitly affected versions
2.3.0, 2.3.1, 2.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3"
},
{
"fixed": "2.3.2-p1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.3.0",
"2.3.1",
"2.3.2"
]
}