imdbphp Cross-Site Scripting (XSS)
The advisory, in context
A Cross-Site Scripting (XSS) was discovered in imdbphp 5.1.1. The vulnerability exists due to insufficient filtration of user-supplied data (name) passed to the "imdbphp-master/demo/search.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 5.2.0
Fixed in 5.2.0
33 explicitly affected versions
2.2.4, 2.3.0, 2.3.1, 2.3.2, 2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.4.0, v2.4.1, v2.5, v2.6.0, v2.6.1, v3.0.0, v3.0.1, v3.0.2, v3.1.0, v3.1.1, v3.1.2, v3.1.4, v3.1.5, v3.2.0, v3.3.0, v4.0.0, v4.0.1, v4.1.0, v4.1.1, v5.0.0, v5.0.1, v5.0.2, v5.0.3, v5.1.0, v5.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.4",
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.3",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.4.0",
"v2.4.1",
"v2.5",
"v2.6.0",
"v2.6.1",
"v3.0.0",
"v3.0.1",
"v3.0.2",
"v3.1.0",
"v3.1.1",
"v3.1.2",
"v3.1.4",
"v3.1.5",
"v3.2.0",
"v3.3.0",
"v4.0.0",
"v4.0.1",
"v4.1.0",
"v4.1.1",
"v5.0.0",
"v5.0.1",
"v5.0.2",
"v5.0.3",
"v5.1.0",
"v5.1.1"
]
}