Insecure Deserialization in TYPO3 CMS
The advisory, in context
It has been discovered that the Form Framework (system extension "form") is vulnerable to Insecure Deserialization when being used with the additional PHP PECL package “yaml”, which is capable of unserializing YAML contents to PHP objects. A valid backend user account as well as having PHP setting "yaml.decode_php" enabled is needed to exploit this vulnerability (which is the default value according to PHP documentation).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.5.0 before 8.7.17
Fixed in 8.7.17
21 explicitly affected versions
8.5.0, 8.5.1, 8.6.0, 8.6.1, 8.7.0, 8.7.1, 8.7.2, v8.7.10, v8.7.11, v8.7.12, v8.7.13, v8.7.14, v8.7.15, v8.7.16, v8.7.3, v8.7.4, v8.7.5, v8.7.6, v8.7.7, v8.7.8, v8.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.5.0"
},
{
"fixed": "8.7.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.5.0",
"8.5.1",
"8.6.0",
"8.6.1",
"8.7.0",
"8.7.1",
"8.7.2",
"v8.7.10",
"v8.7.11",
"v8.7.12",
"v8.7.13",
"v8.7.14",
"v8.7.15",
"v8.7.16",
"v8.7.3",
"v8.7.4",
"v8.7.5",
"v8.7.6",
"v8.7.7",
"v8.7.8",
"v8.7.9"
]
}From 9.0.0 before 9.3.2
Fixed in 9.3.2
6 explicitly affected versions
v9.0.0, v9.1.0, v9.2.0, v9.2.1, v9.3.0, v9.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.3.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v9.0.0",
"v9.1.0",
"v9.2.0",
"v9.2.1",
"v9.3.0",
"v9.3.1"
]
}