Potential Remote Code Execution vulnerability
The advisory, in context
Packages nette/application versions prior to 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette versions prior to 2.0.19 and 2.1.13 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE.
Reported by Cyku Hong from DEVCORE (https://devco.re)
Impact
Code injection, possible remote code execution.
Patches
Fixed in nette/application 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette 2.0.19 and 2.1.13
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.2.0 before 2.2.10
Fixed in 2.2.10
10 explicitly affected versions
v2.2.0, v2.2.1, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.2.0",
"v2.2.1",
"v2.2.2",
"v2.2.3",
"v2.2.4",
"v2.2.5",
"v2.2.6",
"v2.2.7",
"v2.2.8",
"v2.2.9"
]
}From 2.3.0 before 2.3.14
Fixed in 2.3.14
14 explicitly affected versions
v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.2, v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.0",
"v2.3.1",
"v2.3.10",
"v2.3.11",
"v2.3.12",
"v2.3.13",
"v2.3.2",
"v2.3.3",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9"
]
}From 2.4.0 before 2.4.16
Fixed in 2.4.16
16 explicitly affected versions
v2.4.0, v2.4.1, v2.4.10, v2.4.11, v2.4.12, v2.4.13, v2.4.14, v2.4.15, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.4.0",
"v2.4.1",
"v2.4.10",
"v2.4.11",
"v2.4.12",
"v2.4.13",
"v2.4.14",
"v2.4.15",
"v2.4.2",
"v2.4.3",
"v2.4.4",
"v2.4.5",
"v2.4.6",
"v2.4.7",
"v2.4.8",
"v2.4.9"
]
}From 3.0.0 before 3.0.6
Fixed in 3.0.6
7 explicitly affected versions
v3.0.0, v3.0.1, v3.0.2, v3.0.2.1, v3.0.3, v3.0.4, v3.0.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.0.0",
"v3.0.1",
"v3.0.2",
"v3.0.2.1",
"v3.0.3",
"v3.0.4",
"v3.0.5"
]
}From 2.0.0 before 2.0.19
Fixed in 2.0.19
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.19"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 2.1.0 before 2.1.13
Fixed in 2.1.13
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://github.com/nette/application/security/advisories/GHSA-8gv3-3j7f-wg94
- https://nvd.nist.gov/vuln/detail/CVE-2020-15227
- https://blog.nette.org/en/cve-2020-15227-potential-remote-code-execution-vulnerability
- https://github.com/FriendsOfPHP/security-advisories/blob/master/nette/application/CVE-2020-15227.yaml
- https://github.com/nette/application
- https://lists.debian.org/debian-lts-announce/2021/04/msg00003.html
- https://packagist.org/packages/nette/application
- https://packagist.org/packages/nette/nette