GHSA-8fcv-4qp9-pg32medium4.3
Moodle sends quiz-related messages to inactive/suspended users
The advisory, in context
Moodle failed to verify enrolment status correctly when sending quiz notifications. As a result, suspended or inactive users might receive quiz-related messages, leaking limited course information.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 5.0.0-beta before 5.0.3
Fixed in 5.0.3
7 explicitly affected versions
v5.0.0, v5.0.0-beta, v5.0.0-rc1, v5.0.0-rc2, v5.0.0-rc3, v5.0.1, v5.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-beta"
},
{
"fixed": "5.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.0.0",
"v5.0.0-beta",
"v5.0.0-rc1",
"v5.0.0-rc2",
"v5.0.0-rc3",
"v5.0.1",
"v5.0.2"
]
}moodle/moodle Packagist
Ecosystem versions
From 4.5.0-beta before 4.5.7
Fixed in 4.5.7
10 explicitly affected versions
v4.5.0, v4.5.0-beta, v4.5.0-rc1, v4.5.0-rc2, v4.5.1, v4.5.2, v4.5.3, v4.5.4, v4.5.5, v4.5.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0-beta"
},
{
"fixed": "4.5.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.5.0",
"v4.5.0-beta",
"v4.5.0-rc1",
"v4.5.0-rc2",
"v4.5.1",
"v4.5.2",
"v4.5.3",
"v4.5.4",
"v4.5.5",
"v4.5.6"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-62394
- https://github.com/moodle/moodle/commit/022bfbfb564d8f3866a43d26eed215213bbdd28a
- https://access.redhat.com/security/cve/CVE-2025-62394
- https://bugzilla.redhat.com/show_bug.cgi?id=2404427
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=470383