GHSA-8c76-mxv5-w4g8medium6.8
Stored Cross-site Scripting in Microweber
The advisory, in context
Microweber 1.2.11 and prior contains multiple stored cross-site scripting vulnerabilities in Shop's Other Settings, Shop's Autorespond E-mail Settings and Shops' Payments Methods.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
microweber/microweber Packagist
Ecosystem versions
Earlier releases before 1.2.12
Fixed in 1.2.12
20 explicitly affected versions
0.9.346, 0.93, 0.931, 0.934, 0.951, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.1, v1.2.10, v1.2.11, v1.2.3, v1.2.4, v1.2.5, v1.2.6, v1.2.7, v1.2.8, v1.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.9.346",
"0.93",
"0.931",
"0.934",
"0.951",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.1",
"v1.2.10",
"v1.2.11",
"v1.2.3",
"v1.2.4",
"v1.2.5",
"v1.2.6",
"v1.2.7",
"v1.2.8",
"v1.2.9"
]
}