ibexa/fieldtype-richtext has an XSS vulnerability via acronym custom tag in Rich Text
The advisory, in context
Impact
This security advisory resolves an XSS vulnerability in acronym custom tag in Rich Text, in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless.
Patches
See "Patched versions".
Workarounds
None.
References
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 5.0.0 before 5.0.3
Fixed in 5.0.3
3 explicitly affected versions
v5.0.0, v5.0.1, v5.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.0.0",
"v5.0.1",
"v5.0.2"
]
}From 4.6.0 before 4.6.25
Fixed in 4.6.25
25 explicitly affected versions
v4.6.0, v4.6.1, v4.6.10, v4.6.11, v4.6.12, v4.6.13, v4.6.14, v4.6.15, v4.6.16, v4.6.17, v4.6.18, v4.6.19, v4.6.2, v4.6.20, v4.6.21, v4.6.22, v4.6.23, v4.6.24, v4.6.3, v4.6.4, v4.6.5, v4.6.6, v4.6.7, v4.6.8, v4.6.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6.0"
},
{
"fixed": "4.6.25"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.6.0",
"v4.6.1",
"v4.6.10",
"v4.6.11",
"v4.6.12",
"v4.6.13",
"v4.6.14",
"v4.6.15",
"v4.6.16",
"v4.6.17",
"v4.6.18",
"v4.6.19",
"v4.6.2",
"v4.6.20",
"v4.6.21",
"v4.6.22",
"v4.6.23",
"v4.6.24",
"v4.6.3",
"v4.6.4",
"v4.6.5",
"v4.6.6",
"v4.6.7",
"v4.6.8",
"v4.6.9"
]
}