GHSA-89cp-fvcc-hxh7medium
Symfony Access Control Vulnerability
The advisory, in context
Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a /_internal substring.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
symfony/symfony Packagist
1 explicitly affected versions
2.2-dev
View affected-version evidence
{
"ranges": [],
"versions": [
"2.2-dev"
]
}symfony/symfony Packagist
Ecosystem versions
From 2.0.0 before 2.0.20
Fixed in 2.0.20
15 explicitly affected versions
2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11, v2.0.12, v2.0.13, v2.0.14, v2.0.15, v2.0.16, v2.0.17, v2.0.18, v2.0.19, v2.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.20"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"v2.0.10",
"v2.0.11",
"v2.0.12",
"v2.0.13",
"v2.0.14",
"v2.0.15",
"v2.0.16",
"v2.0.17",
"v2.0.18",
"v2.0.19",
"v2.0.9"
]
}symfony/symfony Packagist
Ecosystem versions
From 2.1.0 before 2.1.5
Fixed in 2.1.5
5 explicitly affected versions
v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.1.0",
"v2.1.1",
"v2.1.2",
"v2.1.3",
"v2.1.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2012-6432
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2012-6432.yaml
- https://github.com/symfony/symfony
- https://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released
- http://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released