GHSA-8787-63px-3m23critical9.8
Cobbler has Exposed Dangerous Method or Function
The advisory, in context
It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
cobbler PyPI
Ecosystem versions
From 2.6.0 before 3.0.0
Fixed in 3.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.6.0"
},
{
"fixed": "3.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10931
- https://github.com/cobbler/cobbler/issues/1916
- https://github.com/cobbler/cobbler/pull/1921
- https://github.com/cobbler/cobbler/commit/1b91a3d3ac87c31d9dac2307513feb2aa49620a6
- https://access.redhat.com/errata/RHSA-2018:2372
- https://access.redhat.com/security/cve/CVE-2018-10931
- https://bugzilla.redhat.com/show_bug.cgi?id=1613861
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10931
- https://github.com/cobbler/cobbler
- https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-313.yaml
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5P5Q4ACIVZ5D4KSUDLGRTOKGGB4U42SD
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CMWK5KCCZXOGOYNR2H6BWDSABTQ5NYJA
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5P5Q4ACIVZ5D4KSUDLGRTOKGGB4U42SD
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CMWK5KCCZXOGOYNR2H6BWDSABTQ5NYJA
- https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api
- https://pypi.org/project/cobbler