GHSA-86v9-gqh9-8268medium
Moodle vulnerable to Cross-site Scripting
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in filter/mediaplugin/filter.php in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) Flash Video (aka FLV) files and (2) YouTube videos.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 1.9.0 before 1.9.11
Fixed in 1.9.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}moodle/moodle Packagist
Ecosystem versions
From 2.0.0 before 2.0.2
Fixed in 2.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4286
- http://git.moodle.org
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=8f81bfd412c6b2e93a5b15711727d5cb7cc78336
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=8f81bfd412c6b2e93a5b15711727d5cb7cc78336
- http://moodle.org/mod/forum/discuss.php?d=170012
- http://openwall.com/lists/oss-security/2011/11/14/1