Concrete CMS Cross-site Scripting vulnerability
Impact
Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 8.5.10Ecosystem versions | 8.5.10 |
| From 9.0.0 before 9.1.3Ecosystem versions | 9.1.3 |
Version evidence: OSV · GHSA-8699-h45g-7hm8
View original version evidence (38 explicit versions)
Original source description
Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2022-43695
- Release notes documentation.concretecms.org/developers/introduction/version-history/8510-release-notes
- Release notes documentation.concretecms.org/developers/introduction/version-history/913-release-notes
- Source reference github.com/concretecms
- Release notes github.com/concretecms/concretecms/releases/8.5.10
- Release notes github.com/concretecms/concretecms/releases/9.1.3
- Security advisory www.concretecms.org/about/project-news/security/concrete-cms-security-advisory-2022-10-31