GHSA-7x6f-jvmg-6fgplow2.1
TYPO3 Direct Mail Extension Vulnerable to Cross-Site Scripting (XSS)
The advisory, in context
Cross-site scripting (XSS) vulnerability in the newsletter configuration feature in the backend module in the Direct Mail (direct_mail) extension 2.6.4 and earlier for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
directmailteam/direct-mail Packagist
Ecosystem versions
Earlier releases before 2.6.5
Fixed in 2.6.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2009-4159
- https://github.com/kartolo/direct_mail
- https://web.archive.org/web/20110108051351/http://typo3.org/teams/security/security-bulletins/typo3-sa-2009-018
- https://web.archive.org/web/20200228220911/http://www.securityfocus.com/bid/37166
- http://typo3.org/extensions/repository/view/direct_mail/2.6.5