GHSA-7r88-wjhj-jr8mhigh8.8
RaspAP Command Injection vulnerability
The advisory, in context
A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated attacker to execute arbitrary OS commands as root via the entity POST parameters in /ajax/networking/get_wgkey.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
billz/raspap-webgui Packagist
Ecosystem versions
From 2.8.0 before 2.9.5
Fixed in 2.9.5
15 explicitly affected versions
2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.8.5, 2.8.6, 2.8.7, 2.8.8, 2.8.9, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.8.0"
},
{
"fixed": "2.9.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.8.0",
"2.8.1",
"2.8.2",
"2.8.3",
"2.8.4",
"2.8.5",
"2.8.6",
"2.8.7",
"2.8.8",
"2.8.9",
"2.9.0",
"2.9.1",
"2.9.2",
"2.9.3",
"2.9.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-39987
- https://github.com/RaspAP/raspap-webgui/pull/1395
- https://github.com/RaspAP/raspap-webgui/commit/e87e7d1d3a61617430851f2a040379de1ff3dd9d
- https://github.com/RaspAP/raspap-webgui
- https://github.com/RaspAP/raspap-webgui/blob/master/ajax/networking/get_wgkey.php
- https://github.com/RaspAP/raspap-webgui/releases/tag/2.9.5
- https://medium.com/@ismael0x00/multiple-vulnerabilities-in-raspap-3c35e78809f2