GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-7r32-vfj5-c2jvmedium6.1

Code Snippet GeSHi plugin in CKEditor 4 has reflected cross-site scripting (XSS) vulnerability

Check your stack

The advisory, in context

Affected packages

The vulnerability has been discovered in Code Snippet GeSHi plugin. All integrators that use GeSHi syntax highlighter on the backend side can be affected.

Impact

A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by the victim.

The GeSHi library was included as a vendor dependency in CKEditor 4 source files. In a specific scenario, an attacker could craft a malicious script that could be executed by sending a request to the GeSHi library hosted on a PHP web server.

Patches

The GeSHi library is no longer actively maintained. Due to the lack of ongoing support and updates, potential security vulnerabilities have been identified with its continued use. To mitigate these risks and enhance the overall security of the CKEditor 4, we have decided to completely remove the GeSHi library as a dependency. This change aims to maintain a secure environment and reduce the risk of any security incidents related to outdated or unsupported software.

To integrators who still want to use the GeSHi syntax highlighter, we recommend manually adding the GeSHi library . Please be aware of and understand the potential security vulnerabilities associated with its use.

The fix is be available in version 4.25.0-lts.

Acknowledgements

The CKEditor 4 team would like to thank Jiasheng He from Qihoo 360 for recognizing and reporting this vulnerability.

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Semantic versions

Earlier releases before 4.25.0

Fixed in 4.25.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "4.25.0"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
Ecosystem versions

Earlier releases before 4.25.0

Fixed in 4.25.0

67 explicitly affected versions

4.10.0, 4.10.1, 4.11.0, 4.11.1, 4.11.2, 4.11.3, 4.11.4, 4.12.0, 4.12.1, 4.13.0, 4.13.1, 4.14.0, 4.14.1, 4.15.0, 4.15.1, 4.16.0, 4.16.1, 4.16.2, 4.17.0, 4.17.1, 4.17.2, 4.18.0, 4.19.0, 4.19.1, 4.20.0, 4.20.1, 4.20.2, 4.21.0, 4.22.0, 4.22.1, 4.23.0, 4.24.0, 4.3.3, 4.3.4, 4.3.5, 4.4.0, 4.4.1, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.5.0, 4.5.1, 4.5.10, 4.5.11, 4.5.2, 4.5.3, 4.5.4, 4.5.5, 4.5.6, 4.5.7, 4.5.8, 4.5.9, 4.6.0, 4.6.1, 4.6.2, 4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.8.0, 4.9.0, 4.9.1, 4.9.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "4.25.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "4.10.0",
    "4.10.1",
    "4.11.0",
    "4.11.1",
    "4.11.2",
    "4.11.3",
    "4.11.4",
    "4.12.0",
    "4.12.1",
    "4.13.0",
    "4.13.1",
    "4.14.0",
    "4.14.1",
    "4.15.0",
    "4.15.1",
    "4.16.0",
    "4.16.1",
    "4.16.2",
    "4.17.0",
    "4.17.1",
    "4.17.2",
    "4.18.0",
    "4.19.0",
    "4.19.1",
    "4.20.0",
    "4.20.1",
    "4.20.2",
    "4.21.0",
    "4.22.0",
    "4.22.1",
    "4.23.0",
    "4.24.0",
    "4.3.3",
    "4.3.4",
    "4.3.5",
    "4.4.0",
    "4.4.1",
    "4.4.2",
    "4.4.3",
    "4.4.4",
    "4.4.5",
    "4.4.6",
    "4.4.7",
    "4.4.8",
    "4.5.0",
    "4.5.1",
    "4.5.10",
    "4.5.11",
    "4.5.2",
    "4.5.3",
    "4.5.4",
    "4.5.5",
    "4.5.6",
    "4.5.7",
    "4.5.8",
    "4.5.9",
    "4.6.0",
    "4.6.1",
    "4.6.2",
    "4.7.0",
    "4.7.1",
    "4.7.2",
    "4.7.3",
    "4.8.0",
    "4.9.0",
    "4.9.1",
    "4.9.2"
  ]
}

References