GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-7q44-r25x-wm4qhigh8.1

Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows

Check your stack

The advisory, in context

PHPMailer 6.4.1 contains a possible remote code execution vulnerability through the $lang_path parameter of the setLanguage() method. If the $lang_path parameter is passed unfiltered from user input, it can be set to a UNC path, and if an attacker is also able to create a remote mount on the server that the UNC path points to, a script file under their control may be executed.

Impact

Arbitrary code may be run by a remote attacker under the web server or PHP process running on Window hosts.

Patches

Mitigated in PHPMailer 6.5.0 by no longer treating translation files as PHP code, but by parsing their text content directly. This approach avoids the possibility of executing unknown code while retaining backward compatibility. This isn't ideal, so the current translation format is deprecated and will be replaced in the next major release.

Workarounds

Any of:

  • Ensure that calling code does not pass unfiltered user-supplied data to the $lang_path parameter of the setLanguage() method.
  • Block or filter the use of unknown UNC paths in this parameter (or altogether).
  • Ensure that unauthorised users do not have the ability to read from unknown remote servers via UNC paths.
  • Run on an OS that does not support UNC paths

References

CVE-2021-34551.

Reported by listensec.com via Tidelift.

For more information

If you have any questions or comments about this advisory:

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 6.5.0

Fixed in 6.5.0

52 explicitly affected versions

v5.2.10, v5.2.11, v5.2.12, v5.2.13, v5.2.14, v5.2.15, v5.2.16, v5.2.17, v5.2.18, v5.2.19, v5.2.2, v5.2.20, v5.2.21, v5.2.22, v5.2.23, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.4, v5.2.5, v5.2.6, v5.2.7, v5.2.8, v5.2.9, v6.0.0, v6.0.0rc1, v6.0.0rc2, v6.0.0rc3, v6.0.0rc4, v6.0.0rc5, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.0.5, v6.0.6, v6.0.7, v6.1.0, v6.1.1, v6.1.2, v6.1.3, v6.1.4, v6.1.5, v6.1.6, v6.1.7, v6.1.8, v6.2.0, v6.3.0, v6.4.0, v6.4.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "6.5.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v5.2.10",
    "v5.2.11",
    "v5.2.12",
    "v5.2.13",
    "v5.2.14",
    "v5.2.15",
    "v5.2.16",
    "v5.2.17",
    "v5.2.18",
    "v5.2.19",
    "v5.2.2",
    "v5.2.20",
    "v5.2.21",
    "v5.2.22",
    "v5.2.23",
    "v5.2.24",
    "v5.2.25",
    "v5.2.26",
    "v5.2.27",
    "v5.2.28",
    "v5.2.4",
    "v5.2.5",
    "v5.2.6",
    "v5.2.7",
    "v5.2.8",
    "v5.2.9",
    "v6.0.0",
    "v6.0.0rc1",
    "v6.0.0rc2",
    "v6.0.0rc3",
    "v6.0.0rc4",
    "v6.0.0rc5",
    "v6.0.1",
    "v6.0.2",
    "v6.0.3",
    "v6.0.4",
    "v6.0.5",
    "v6.0.6",
    "v6.0.7",
    "v6.1.0",
    "v6.1.1",
    "v6.1.2",
    "v6.1.3",
    "v6.1.4",
    "v6.1.5",
    "v6.1.6",
    "v6.1.7",
    "v6.1.8",
    "v6.2.0",
    "v6.3.0",
    "v6.4.0",
    "v6.4.1"
  ]
}

References