GHSA-7mqg-5fgh-xh4rhigh7.5
MediaWiki Incorrect Access Control vulnerability
Impact
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mediawiki/core Packagist
| Affected range | Recorded fix |
|---|---|
| From 1.18.0 before 1.27.6Ecosystem versions | 1.27.6 |
| From 1.30.0 before 1.30.2Ecosystem versions | 1.30.2 |
| From 1.31.0 before 1.31.2Ecosystem versions | 1.31.2 |
| From 1.32.0 before 1.32.2Ecosystem versions | 1.32.2 |
Version evidence: OSV · GHSA-7mqg-5fgh-xh4r
View original version evidence (57 explicit versions)
Original source description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2019-12472
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12472.yaml
- Source reference github.com/wikimedia/mediawiki
- Source reference lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- Source reference phabricator.wikimedia.org/T199540