GHSA-7mg5-rw39-q67fcritical9.8
himiklab yii2-jqgrid-widget vulnerable to SQL Injection
The advisory, in context
A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 can address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
himiklab/yii2-jqgrid-widget Packagist
Ecosystem versions
Earlier releases before 1.0.8
Fixed in 1.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-125051
- https://github.com/himiklab/yii2-jqgrid-widget/commit/a117e0f2df729e3ff726968794d9a5ac40e660b9
- https://github.com/himiklab/yii2-jqgrid-widget
- https://github.com/himiklab/yii2-jqgrid-widget/releases/tag/1.0.8
- https://vuldb.com/?ctiid.217564
- https://vuldb.com/?id.217564