smarty Cross-site Scripting vulnerability in Javascript escaping
The advisory, in context
Impact
An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0.0 before 4.3.1
Fixed in 4.3.1
10 explicitly affected versions
v4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.4, v4.1.0, v4.1.1, v4.2.0, v4.2.1, v4.3.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.3.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.0",
"v4.0.1",
"v4.0.2",
"v4.0.3",
"v4.0.4",
"v4.1.0",
"v4.1.1",
"v4.2.0",
"v4.2.1",
"v4.3.0"
]
}Earlier releases before 3.1.48
Fixed in 3.1.48
46 explicitly affected versions
v2.6.24, v2.6.25, v2.6.26, v2.6.27, v2.6.28, v2.6.29, v2.6.30, v2.6.31, v2.6.33, v3.1.11, v3.1.12, v3.1.13, v3.1.14, v3.1.15, v3.1.16, v3.1.17, v3.1.18, v3.1.19, v3.1.20, v3.1.21, v3.1.23, v3.1.24, v3.1.25, v3.1.26, v3.1.27, v3.1.28, v3.1.29, v3.1.30, v3.1.31, v3.1.32, v3.1.33, v3.1.34, v3.1.35, v3.1.36, v3.1.37, v3.1.37.1, v3.1.38, v3.1.39, v3.1.40, v3.1.41, v3.1.42, v3.1.43, v3.1.44, v3.1.45, v3.1.46, v3.1.47
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.48"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.6.24",
"v2.6.25",
"v2.6.26",
"v2.6.27",
"v2.6.28",
"v2.6.29",
"v2.6.30",
"v2.6.31",
"v2.6.33",
"v3.1.11",
"v3.1.12",
"v3.1.13",
"v3.1.14",
"v3.1.15",
"v3.1.16",
"v3.1.17",
"v3.1.18",
"v3.1.19",
"v3.1.20",
"v3.1.21",
"v3.1.23",
"v3.1.24",
"v3.1.25",
"v3.1.26",
"v3.1.27",
"v3.1.28",
"v3.1.29",
"v3.1.30",
"v3.1.31",
"v3.1.32",
"v3.1.33",
"v3.1.34",
"v3.1.35",
"v3.1.36",
"v3.1.37",
"v3.1.37.1",
"v3.1.38",
"v3.1.39",
"v3.1.40",
"v3.1.41",
"v3.1.42",
"v3.1.43",
"v3.1.44",
"v3.1.45",
"v3.1.46",
"v3.1.47"
]
}References
- https://github.com/smarty-php/smarty/security/advisories/GHSA-7j98-h7fp-4vwj
- https://nvd.nist.gov/vuln/detail/CVE-2023-28447
- https://github.com/smarty-php/smarty/commit/685662466f653597428966d75a661073104d713d
- https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2023-28447.yaml
- https://github.com/smarty-php/smarty
- https://lists.debian.org/debian-lts-announce/2024/11/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HSAUM3YHWHO4UCJXRGRLQGPJAO3MFOZZ
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JBB35GLYTL6JL6EOM6BOZNYP47JKNNHT
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/P7O7SKTATM6GAP45S64QFXNLWIY5I7HP