GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

All vulnerabilities
GHSA-7hp6-4w63-5g45critical9.9

LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key

Check your stack

The advisory, in context

Summary

An authenticated user with internal_user privileges can escalate to proxy_admin and achieve remote code execution. The proxy uses one encryption key for two purposes: sealing secrets at rest and minting session tokens. An attacker exploits this by requesting a new API key with a crafted metadata field containing a forged admin credential as the "secret" value. The proxy encrypts and returns this payload. When this value is then presented as a bearer token, the proxy decrypts it, trusts the forged admin identity, and grants full administrative access, including the ability to execute arbitrary commands via the MCP stdio endpoint.

Affected versions

Versions later than 1.91.0 are exploitable in the default configuration. Versions 1.87.0 through 1.90.x are exploitable only if EXPERIMENTAL_UI_LOGIN=true was explicitly set.

Mitigation

Upgrade to a patched version as soon as possible.

If you cannot upgrade immediately, set EXPERIMENTAL_UI_LOGIN=false. This disables the vulnerable authentication path but also breaks CLI SSO and Claude Code gateway login.

Impact

An internal user can escalate to proxy admin and execute arbitrary commands on the host.

Discovery Credit: Hoa X. Nguyen (OPSWAT Unit 515)

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 1.91.0 before 1.100.4

Fixed in 1.100.4

62 explicitly affected versions

1.100.0, 1.100.0.dev1, 1.100.0.dev2, 1.100.0rc1, 1.100.1, 1.100.2, 1.100.3, 1.91.0, 1.91.1, 1.91.2, 1.91.3, 1.91.4, 1.91.5, 1.92.0, 1.92.0.dev1, 1.92.0.dev2, 1.92.0rc1, 1.92.0rc2, 1.92.1, 1.92.2, 1.93.0, 1.93.0.dev1, 1.93.0.dev2, 1.93.0.dev3, 1.93.0rc1, 1.93.0rc2, 1.93.1, 1.93.2, 1.94.0, 1.94.0.dev3, 1.94.0rc1, 1.94.0rc2, 1.94.0rc3, 1.94.1, 1.94.2, 1.94.3, 1.95.0, 1.95.0.dev3, 1.95.0rc1, 1.95.0rc2, 1.95.0rc3, 1.95.1, 1.96.0, 1.96.0.dev2, 1.96.0rc1, 1.96.2, 1.97.0, 1.97.0.dev1, 1.97.0rc1, 1.98.0, 1.98.0.dev1, 1.98.0.dev2, 1.98.0rc1, 1.98.1, 1.99.0, 1.99.0.dev1, 1.99.0.dev2, 1.99.0rc1, 1.99.0rc2, 1.99.2, 1.99.3, 1.99.4

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.91.0"
        },
        {
          "fixed": "1.100.4"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.100.0",
    "1.100.0.dev1",
    "1.100.0.dev2",
    "1.100.0rc1",
    "1.100.1",
    "1.100.2",
    "1.100.3",
    "1.91.0",
    "1.91.1",
    "1.91.2",
    "1.91.3",
    "1.91.4",
    "1.91.5",
    "1.92.0",
    "1.92.0.dev1",
    "1.92.0.dev2",
    "1.92.0rc1",
    "1.92.0rc2",
    "1.92.1",
    "1.92.2",
    "1.93.0",
    "1.93.0.dev1",
    "1.93.0.dev2",
    "1.93.0.dev3",
    "1.93.0rc1",
    "1.93.0rc2",
    "1.93.1",
    "1.93.2",
    "1.94.0",
    "1.94.0.dev3",
    "1.94.0rc1",
    "1.94.0rc2",
    "1.94.0rc3",
    "1.94.1",
    "1.94.2",
    "1.94.3",
    "1.95.0",
    "1.95.0.dev3",
    "1.95.0rc1",
    "1.95.0rc2",
    "1.95.0rc3",
    "1.95.1",
    "1.96.0",
    "1.96.0.dev2",
    "1.96.0rc1",
    "1.96.2",
    "1.97.0",
    "1.97.0.dev1",
    "1.97.0rc1",
    "1.98.0",
    "1.98.0.dev1",
    "1.98.0.dev2",
    "1.98.0rc1",
    "1.98.1",
    "1.99.0",
    "1.99.0.dev1",
    "1.99.0.dev2",
    "1.99.0rc1",
    "1.99.0rc2",
    "1.99.2",
    "1.99.3",
    "1.99.4"
  ]
}
Ecosystem versions

From 1.101.0 before 1.101.3

Fixed in 1.101.3

3 explicitly affected versions

1.101.0, 1.101.1, 1.101.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.101.0"
        },
        {
          "fixed": "1.101.3"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.101.0",
    "1.101.1",
    "1.101.2"
  ]
}
Ecosystem versions

From 1.102.0 before 1.102.2

Fixed in 1.102.2

2 explicitly affected versions

1.102.0, 1.102.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.102.0"
        },
        {
          "fixed": "1.102.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.102.0",
    "1.102.1"
  ]
}
Ecosystem versions

From 1.103.0 before 1.103.1

Fixed in 1.103.1

1 explicitly affected versions

1.103.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.103.0"
        },
        {
          "fixed": "1.103.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.103.0"
  ]
}
Ecosystem versions

From 1.104.0rc1 before 1.104.0rc2

Fixed in 1.104.0rc2

1 explicitly affected versions

1.104.0rc1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.104.0rc1"
        },
        {
          "fixed": "1.104.0rc2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.104.0rc1"
  ]
}

References