Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency
The advisory, in context
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Users are affected if they meet the following preconditions:
- Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0,
- Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.
Resolution
Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 7.0.0 before 7.20.0
Fixed in 7.20.0
28 explicitly affected versions
7.0.0, 7.0.1, 7.1.0, 7.10.0, 7.10.1, 7.11.0, 7.12.0, 7.13.0, 7.14.0, 7.15.0, 7.16.0, 7.17.0, 7.18.0, 7.19.0, 7.2.0, 7.2.1, 7.2.2, 7.3.0, 7.4.0, 7.5.0, 7.5.1, 7.5.2, 7.6.0, 7.7.0, 7.8.0, 7.8.1, 7.9.0, 7.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.20.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.0.0",
"7.0.1",
"7.1.0",
"7.10.0",
"7.10.1",
"7.11.0",
"7.12.0",
"7.13.0",
"7.14.0",
"7.15.0",
"7.16.0",
"7.17.0",
"7.18.0",
"7.19.0",
"7.2.0",
"7.2.1",
"7.2.2",
"7.3.0",
"7.4.0",
"7.5.0",
"7.5.1",
"7.5.2",
"7.6.0",
"7.7.0",
"7.8.0",
"7.8.1",
"7.9.0",
"7.9.1"
]
}