GHSA-7cvw-wrj9-q5fpmedium6.6
Moodle vulnerable to Cross-Site Request Forgery
The advisory, in context
Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 1.9.0 before 1.9.11
Fixed in 1.9.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4133
- https://github.com/moodle/moodle
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=8f031d5431c1204197b1482fd6c63bc87a19a476
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=8f031d5431c1204197b1482fd6c63bc87a19a476
- http://moodle.org/mod/forum/discuss.php?d=170002
- http://openwall.com/lists/oss-security/2011/11/14/1