GHSA-7cfq-72w2-24q4critical9.8
Yii2 allows attackers to execute any local .php file via a relative path in the view parameter
The advisory, in context
web\ViewAction in Yii (aka Yii2) 2.x before 2.0.5 allows attackers to execute any local .php file via a relative path in the view parameeter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yiisoft/yii2 Packagist
Ecosystem versions
From 2.0.0 before 2.0.5
Fixed in 2.0.5
5 explicitly affected versions
2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5467
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2-dev/CVE-2015-5467.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2/CVE-2015-5467.yaml
- https://github.com/yiisoft/yii2-framework
- https://www.yiiframework.com/news/87/yii-2-0-5-is-released-security-fix