Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI
Impact
Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and ALLOW_ADMIN_CHANGES must be enabled for this to work.
Source excerpt · OSVYou must have administrator access and ALLOW_ADMIN_CHANGES must be enabled for this to work.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 4.0.0-RC1 before 4.14.13Ecosystem versions | 4.14.13 |
| From 5.0.0-RC1 before 5.6.15Ecosystem versions | 5.6.15 |
Version evidence: OSV · GHSA-7c58-g782-9j38
View original version evidence (289 explicit versions)
Original source description
Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and ALLOW_ADMIN_CHANGES must be enabled for this to work.
https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production
Note: This is a follow-up to https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
Users should update to the patched versions (4.14.13 and 5.6.15) to mitigate the issue.
References
References
- Security advisory github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38
- Security advisory github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
- Security advisory nvd.nist.gov/vuln/detail/CVE-2025-46731
- Source reference craftcms.com/knowledge-base/securing-craft
- Source reference github.com/craftcms/cms
- Patch github.com/craftcms/cms/pull/17026