GHSA-79xr-v794-wq35medium6.1
MunkiReport Managed Installs module Reflected Cross-Site Scripting (XSS) vulnerability
The advisory, in context
A Cross-Site Scripting (XSS) vulnerability in the managedinstalls module before 2.6 for MunkiReport allows remote attackers to inject arbitrary web script or HTML via the last two URL parameters (through which installed packages names and versions are reported).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
munkireport/managedinstalls Packagist
Ecosystem versions
Earlier releases before 2.6
Fixed in 2.6
8 explicitly affected versions
V2.3, v1.1, v1.2, v2.0, v2.1, v2.2, v2.4, v2.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"V2.3",
"v1.1",
"v1.2",
"v2.0",
"v2.1",
"v2.2",
"v2.4",
"v2.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-15883
- https://github.com/munkireport/managedinstalls/commit/708f6a2abc4b80a3751bcc9cf896f80d84250c55
- https://github.com/munkireport/managedinstalls
- https://github.com/munkireport/managedinstalls/releases/tag/v2.6
- https://github.com/munkireport/munkireport-php
- https://github.com/munkireport/munkireport-php/releases/tag/v5.6.3
- https://github.com/munkireport/munkireport-php/wiki/20200722-Reflected-XSS-In-Managedinstalls-Module