GHSA-78hm-5hjw-58mhmedium
ua-parser/uap-php ReDoS vulnerability
No CVE assignedCheck your stack
The advisory, in context
A regex expression in ua-parser/uap-php could lead to a ReDoS vulnerability in versions prior to 3.8.0.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
ua-parser/uap-php Packagist
Ecosystem versions
Earlier releases before 3.8.0
Fixed in 3.8.0
11 explicitly affected versions
v3.4.0, v3.4.1, v3.4.2, v3.4.3, v3.4.4, v3.4.5, v3.4.6, v3.4.7, v3.5.0, v3.6.0, v3.7.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.4.0",
"v3.4.1",
"v3.4.2",
"v3.4.3",
"v3.4.4",
"v3.4.5",
"v3.4.6",
"v3.4.7",
"v3.5.0",
"v3.6.0",
"v3.7.0"
]
}References
- https://github.com/ua-parser/uap-core/pull/363
- https://github.com/ua-parser/uap-core/commit/156f7e12b215bddbaf3df4514c399d683e6cdadc
- https://github.com/ua-parser/uap-php/commit/947f80b39130c83a3d1c75900ac1b58828ed8aef
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ua-parser/uap-php/2018-12-14.yaml
- https://github.com/ua-parser/uap-php