Moodle reflected XSS
The advisory, in context
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.10 before 3.10.4
Fixed in 3.10.4
7 explicitly affected versions
v3.10.0, v3.10.0-beta, v3.10.0-rc1, v3.10.0-rc2, v3.10.1, v3.10.2, v3.10.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.10"
},
{
"fixed": "3.10.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.10.0-beta",
"v3.10.0-rc1",
"v3.10.0-rc2",
"v3.10.1",
"v3.10.2",
"v3.10.3"
]
}From 3.9 before 3.9.7
Fixed in 3.9.7
11 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6"
]
}From 3.8 before 3.8.9
Fixed in 3.8.9
11 explicitly affected versions
v3.8.0, v3.8.0-beta, v3.8.0-rc1, v3.8.1, v3.8.2, v3.8.3, v3.8.4, v3.8.5, v3.8.6, v3.8.7, v3.8.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8"
},
{
"fixed": "3.8.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.8.0",
"v3.8.0-beta",
"v3.8.0-rc1",
"v3.8.1",
"v3.8.2",
"v3.8.3",
"v3.8.4",
"v3.8.5",
"v3.8.6",
"v3.8.7",
"v3.8.8"
]
}