GHSA-786g-xv8v-9h93medium5.4
Moodle Cross-site Scripting vulnerability
The advisory, in context
In Moodle, ID numbers displayed in the web service token list required additional sanitizing to prevent a stored XSS risk.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.11 before 3.11.1
Fixed in 3.11.1
5 explicitly affected versions
3.11, v3.11.0, v3.11.0-beta, v3.11.0-rc1, v3.11.0-rc2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11"
},
{
"fixed": "3.11.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.11",
"v3.11.0",
"v3.11.0-beta",
"v3.11.0-rc1",
"v3.11.0-rc2"
]
}