GHSA-779c-7w4p-2c4glow3.8
Silverstripe admin XSS Vulnerability via WYSIWYG editor
No CVE assignedCheck your stack
The advisory, in context
It is possible for a bad actor with access to the CMS to make use of onmouseover or onmouseout attributes in the WYSIWYG editor to embed malicious javascript.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/admin Packagist
Ecosystem versions
From 1.0.3 before 1.0.4
Fixed in 1.0.4
1 explicitly affected versions
1.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.3"
},
{
"fixed": "1.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.3"
]
}silverstripe/admin Packagist
Ecosystem versions
From 1.1.0 before 1.1.1
Fixed in 1.1.1
1 explicitly affected versions
1.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.1.0"
},
{
"fixed": "1.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.1.0"
]
}