GHSA-7644-cxp8-h23rcritical
ibexa/admin-ui vulnerable to Cross-site Scripting in content type name/shortname
No CVE assignedCheck your stack
The advisory, in context
Critical severity. It is possible to inject JavaScript XSS in the content type entries "name" and "short name". To exploit this, one must already have permission to edit content types, which limits it in many cases to people who are already administrators. However, please verify which users have this permission. The fix ensures any injections are escaped.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
ibexa/admin-ui Packagist
Ecosystem versions
From 4.2.0 before 4.2.3
Fixed in 4.2.3
3 explicitly affected versions
v4.2.0, v4.2.1, v4.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.2.0",
"v4.2.1",
"v4.2.2"
]
}