GHSA-74mf-vjpg-9xh7high
Slim vulnerable to PHP object injection
The advisory, in context
Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
slim/slim Packagist
Ecosystem versions
Earlier releases before 2.6.0
Fixed in 2.6.0
22 explicitly affected versions
1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.5.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.6.0",
"1.6.1",
"1.6.2",
"1.6.3",
"1.6.4",
"1.6.5",
"1.6.6",
"1.6.7",
"2.0.0",
"2.1.0",
"2.2.0",
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.3",
"2.3.4",
"2.3.5",
"2.4.0",
"2.4.1",
"2.4.2",
"2.4.3",
"2.5.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-2171
- https://github.com/slimphp/Slim/issues/1034
- https://github.com/slimphp/Slim/commit/9fa651474eb4d3bb0ce40dd5a55c51bb861c2658
- https://github.com/FriendsOfPHP/security-advisories/blob/master/slim/slim/CVE-2015-2171.yaml
- https://github.com/slimphp/Slim
- https://web.archive.org/web/20200229032229/http://www.securityfocus.com/bid/70087
- http://seclists.org/fulldisclosure/2015/Mar/16
- http://www.slimframework.com/2015/03/01/version-260.html