GHSA-73xj-v6gc-g5p5high7.2
Subrion CMS RCE Vulnerability
The advisory, in context
/panel/uploads in Subrion CMS 4.2.1 allows remote attackers to execute arbitrary PHP code via a .pht or .phar file, because the .htaccess file omits these.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
intelliants/subrion Packagist
Ecosystem versions
Earlier releases before 4.2.2
Fixed in 4.2.2
14 explicitly affected versions
v4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.1.0, v4.1.1, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.2.0, v4.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.0",
"v4.0.1",
"v4.0.2",
"v4.0.3",
"v4.0.4",
"v4.0.5",
"v4.1.0",
"v4.1.1",
"v4.1.2",
"v4.1.3",
"v4.1.4",
"v4.1.5",
"v4.2.0",
"v4.2.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-19422
- https://github.com/intelliants/subrion/issues/801
- https://github.com/intelliants/subrion/commit/74359bcfaea424edda6d782a8ac25397c55972ab
- http://packetstormsecurity.com/files/162591/Subrion-CMS-4.2.1-Shell-Upload.html
- http://packetstormsecurity.com/files/173998/Intelliants-Subrion-CMS-4.2.1-Remote-Code-Execution.html