GHSA-738m-f33v-qc2rlow
SMTP Injection in PHPMailer
The advisory, in context
Impact
Attackers could inject arbitrary SMTP commands via by exploiting the fact that valid email addresses may contain line breaks, which are not handled correctly in some contexts.
Patches
Fixed in 5.2.14 in this commit.
Workarounds
Manually strip line breaks from email addresses before passing them to PHPMailer.
References
https://nvd.nist.gov/vuln/detail/CVE-2015-8476
For more information
If you have any questions or comments about this advisory:
- Open a private issue in the PHPMailer project
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmailer/phpmailer Packagist
Ecosystem versions
From 5.0.0 before 5.2.14
Fixed in 5.2.14
11 explicitly affected versions
v5.2.10, v5.2.11, v5.2.12, v5.2.13, v5.2.2, v5.2.4, v5.2.5, v5.2.6, v5.2.7, v5.2.8, v5.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.2.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.2.10",
"v5.2.11",
"v5.2.12",
"v5.2.13",
"v5.2.2",
"v5.2.4",
"v5.2.5",
"v5.2.6",
"v5.2.7",
"v5.2.8",
"v5.2.9"
]
}References
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-738m-f33v-qc2r
- https://nvd.nist.gov/vuln/detail/CVE-2015-8476
- https://github.com/PHPMailer/PHPMailer/commit/6687a96a18b8f12148881e4ddde795ae477284b0
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2015-8476.yaml
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.14
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177130.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177139.html
- http://www.debian.org/security/2015/dsa-3416
- http://www.openwall.com/lists/oss-security/2015/12/04/5
- http://www.openwall.com/lists/oss-security/2015/12/05/1
- http://www.securityfocus.com/bid/78619