Pixelfed may allow unauthorized actor to view private posts and private users
The advisory, in context
Pixelfed before 0.12.5 allows anyone to follow private accounts and see private posts on other Fediverse servers. This affects users elsewhere in the Fediverse, if they otherwise have any followers from a Pixelfed instance.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.12.5
Fixed in 0.12.5
42 explicitly affected versions
v0.1.9, v0.10.0, v0.10.1, v0.10.10, v0.10.2, v0.10.3, v0.10.4, v0.10.5, v0.10.6, v0.10.7, v0.10.8, v0.10.9, v0.11.0, v0.11.1, v0.11.10, v0.11.11, v0.11.12, v0.11.13, v0.11.2, v0.11.3, v0.11.4, v0.11.5, v0.11.6, v0.11.7, v0.11.8, v0.11.9, v0.12.0, v0.12.1, v0.12.2, v0.12.3, v0.12.4, v0.5.9, v0.6.0, v0.6.1, v0.7.6, v0.8.0, v0.8.5, v0.8.6, v0.9.0, v0.9.4, v0.9.5, v0.9.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.12.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.9",
"v0.10.0",
"v0.10.1",
"v0.10.10",
"v0.10.2",
"v0.10.3",
"v0.10.4",
"v0.10.5",
"v0.10.6",
"v0.10.7",
"v0.10.8",
"v0.10.9",
"v0.11.0",
"v0.11.1",
"v0.11.10",
"v0.11.11",
"v0.11.12",
"v0.11.13",
"v0.11.2",
"v0.11.3",
"v0.11.4",
"v0.11.5",
"v0.11.6",
"v0.11.7",
"v0.11.8",
"v0.11.9",
"v0.12.0",
"v0.12.1",
"v0.12.2",
"v0.12.3",
"v0.12.4",
"v0.5.9",
"v0.6.0",
"v0.6.1",
"v0.7.6",
"v0.8.0",
"v0.8.5",
"v0.8.6",
"v0.9.0",
"v0.9.4",
"v0.9.5",
"v0.9.6"
]
}