GHSA-6wqp-7g94-f69jmedium6.1
sensiolabs/connect has a Cross-Site Request Forgery Vulnerability
No CVE assignedCheck your stack
The advisory, in context
Versions of sensiolabs/connect prior to 4.2.3 are affected by a Cross-Site Request Forgery (CSRF) vulnerability due to the absence of the state parameter in OAuth requests. The lack of proper state parameter handling exposes applications to CSRF attacks during the OAuth authentication flow.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
sensiolabs/connect Packagist
Ecosystem versions
Earlier releases before 4.2.3
Fixed in 4.2.3
20 explicitly affected versions
v1.0, v1.1, v1.2, v1.3, v1.4, v1.5, v1.6, v1.7, v1.8, v1.9, v2.0.0, v2.0.1, v2.0.2, v2.1.0, v3.0.0, v4.0.0, v4.1.0, v4.2.0, v4.2.1, v4.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.0",
"v1.1",
"v1.2",
"v1.3",
"v1.4",
"v1.5",
"v1.6",
"v1.7",
"v1.8",
"v1.9",
"v2.0.0",
"v2.0.1",
"v2.0.2",
"v2.1.0",
"v3.0.0",
"v4.0.0",
"v4.1.0",
"v4.2.0",
"v4.2.1",
"v4.2.2"
]
}