GHSA-6w4v-qr4m-97gghigh8.1
Multi-Factor Authentication issue in Laravel Fortify
The advisory, in context
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
laravel/fortify Packagist
Ecosystem versions
Earlier releases before 1.11.1
Fixed in 1.11.1
43 explicitly affected versions
v0.0.1, v1.0.0, v1.0.1, v1.1.0, v1.10.0, v1.10.1, v1.10.2, v1.11.0, v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.4.3, v1.5.0, v1.6.0, v1.6.1, v1.6.2, v1.7.0, v1.7.1, v1.7.10, v1.7.11, v1.7.12, v1.7.13, v1.7.14, v1.7.2, v1.7.3, v1.7.4, v1.7.5, v1.7.6, v1.7.7, v1.7.8, v1.7.9, v1.8.0, v1.8.1, v1.8.2, v1.8.3, v1.8.4, v1.8.5, v1.8.6, v1.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.11.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.0.1",
"v1.0.0",
"v1.0.1",
"v1.1.0",
"v1.10.0",
"v1.10.1",
"v1.10.2",
"v1.11.0",
"v1.2.0",
"v1.2.1",
"v1.3.0",
"v1.3.1",
"v1.4.0",
"v1.4.1",
"v1.4.2",
"v1.4.3",
"v1.5.0",
"v1.6.0",
"v1.6.1",
"v1.6.2",
"v1.7.0",
"v1.7.1",
"v1.7.10",
"v1.7.11",
"v1.7.12",
"v1.7.13",
"v1.7.14",
"v1.7.2",
"v1.7.3",
"v1.7.4",
"v1.7.5",
"v1.7.6",
"v1.7.7",
"v1.7.8",
"v1.7.9",
"v1.8.0",
"v1.8.1",
"v1.8.2",
"v1.8.3",
"v1.8.4",
"v1.8.5",
"v1.8.6",
"v1.9.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25838
- https://github.com/laravel/fortify/issues/201
- https://github.com/laravel/fortify/issues/201#issuecomment-1009282153
- https://github.com/laravel/fortify/pull/357
- https://github.com/laravel/fortify/pull/358
- https://github.com/FriendsOfPHP/security-advisories/blob/master/laravel/fortify/CVE-2022-25838.yaml
- https://github.com/advisories/GHSA-6w4v-qr4m-97gg
- https://github.com/laravel/fortify