GHSA-6vfg-8ppv-h5hgmedium5.3
MediaWiki Incorrect Access Control vulnerability
Impact
MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mediawiki/core Packagist
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 1.27.6Ecosystem versions | 1.27.6 |
| From 1.30.0 before 1.30.2Ecosystem versions | 1.30.2 |
| From 1.31.0 before 1.31.2Ecosystem versions | 1.31.2 |
| From 1.32.0 before 1.32.2Ecosystem versions | 1.32.2 |
Version evidence: OSV · GHSA-6vfg-8ppv-h5hg
View original version evidence (57 explicit versions)
Original source description
MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2019-12467
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12467.yaml
- Source reference github.com/wikimedia/mediawiki
- Source reference lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- Source reference phabricator.wikimedia.org/T209794
- Source reference seclists.org/bugtraq/2019/Jun/12
- Security advisory www.debian.org/security/2019/dsa-4460