Improper Certificate Validation in node-sass affects eZ Platform
Impact
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 1.5.0 before 1.5.27Ecosystem versions | 1.5.27 |
Version evidence: OSV · GHSA-6v6p-g8cg-2hgg
View original version evidence (30 explicit versions)
Original source description
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
References
- Security advisory github.com/ezsystems/ezplatform-admin-ui/security/advisories/GHSA-6v6p-g8cg-2hgg
- Security advisory nvd.nist.gov/vuln/detail/CVE-2020-24025
- Security advisory developers.ibexa.co/security-advisories/ibexa-sa-2022-002-vulnerability-in-node-sass
- Security advisory github.com/advisories/GHSA-r8f7-9pfq-mjmv
- Source reference github.com/ezsystems/ezplatform-admin-ui
- Release notes github.com/ezsystems/ezplatform-admin-ui/releases/tag/v1.5.27