FrameworkUserBundle Generates Error Message Containing Sensitive Information
The advisory, in context
A vulnerability was found in sumocoders FrameworkUserBundle up to 1.3.x. It has been rated as problematic. Affected by this issue is some unknown functionality of the file Resources/views/Security/login.html.twig. The manipulation leads to information exposure through error message. Upgrading to version 1.4.0 can address this issue. The name of the patch is abe4993390ba9bd7821ab12678270556645f94c8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217268.
NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.4.0
Fixed in 1.4.0
11 explicitly affected versions
v1.0.0, v1.1.0, v1.1.1, v1.1.2, v1.2.0, v1.2.1, v1.2.2, v1.2.3, v1.2.4, v1.3.0, v1.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.0.0",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.2.0",
"v1.2.1",
"v1.2.2",
"v1.2.3",
"v1.2.4",
"v1.3.0",
"v1.3.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-10012
- https://github.com/sumocoders/FrameworkUserBundle/commit/abe4993390ba9bd7821ab12678270556645f94c8
- https://github.com/sumocoders/FrameworkUserBundle
- https://github.com/sumocoders/FrameworkUserBundle/releases/tag/v1.4.0
- https://vuldb.com/?ctiid.217268
- https://vuldb.com/?id.217268