GHSA-6jhm-4vmx-mr76critical9.8
SQL injection in Moodle
The advisory, in context
A flaw was found in Moodle in versions 3.11 to 3.11.4. An SQL injection risk was identified in the h5p activity web service responsible for fetching user attempt data.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.11 before 3.11.5
Fixed in 3.11.5
8 explicitly affected versions
v3.11.0, v3.11.0-beta, v3.11.0-rc1, v3.11.0-rc2, v3.11.1, v3.11.2, v3.11.3, v3.11.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11"
},
{
"fixed": "3.11.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.11.0",
"v3.11.0-beta",
"v3.11.0-rc1",
"v3.11.0-rc2",
"v3.11.1",
"v3.11.2",
"v3.11.3",
"v3.11.4"
]
}