GHSA-6grv-hw8g-4gfmmedium6.1
PrestaShop Cross-site Scripting vulnerability
The advisory, in context
In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
prestashop/prestashop Packagist
Ecosystem versions
From 1.7.5.2 before 1.7.6.0
Fixed in 1.7.6.0
4 explicitly affected versions
1.7.5.2, 1.7.6.0-beta.1, 1.7.6.0-rc.1, 1.7.6.0-rc.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.7.5.2"
},
{
"fixed": "1.7.6.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.7.5.2",
"1.7.6.0-beta.1",
"1.7.6.0-rc.1",
"1.7.6.0-rc.2"
]
}