GHSA-6fxm-r8p3-mx5clow2.3
Concrete CMS is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file rescan()
The advisory, in context
Concrete CMS 9 before 9.5.0 is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file rescan().
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
concrete5/concrete5 Packagist
Ecosystem versions
From 9.0.0RC1 before 9.5.1
Fixed in 9.5.1
45 explicitly affected versions
9.0.0, 9.0.0RC1, 9.0.0RC3, 9.0.0RC4, 9.0.1, 9.0.2, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.2.0, 9.2.0RC2, 9.2.1, 9.2.2, 9.2.3, 9.2.4, 9.2.5, 9.2.6, 9.2.7, 9.2.8, 9.2.9, 9.3.0, 9.3.1, 9.3.2, 9.3.3, 9.3.4, 9.3.5, 9.3.6, 9.3.7, 9.3.8, 9.3.9, 9.4.0, 9.4.0RC1, 9.4.0RC2, 9.4.1, 9.4.2, 9.4.3, 9.4.4, 9.4.5, 9.4.6, 9.4.7, 9.4.8, 9.5.0, 9.5.0RC1, 9.5.0RC2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0RC1"
},
{
"fixed": "9.5.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0",
"9.0.0RC1",
"9.0.0RC3",
"9.0.0RC4",
"9.0.1",
"9.0.2",
"9.1.0",
"9.1.1",
"9.1.2",
"9.1.3",
"9.2.0",
"9.2.0RC2",
"9.2.1",
"9.2.2",
"9.2.3",
"9.2.4",
"9.2.5",
"9.2.6",
"9.2.7",
"9.2.8",
"9.2.9",
"9.3.0",
"9.3.1",
"9.3.2",
"9.3.3",
"9.3.4",
"9.3.5",
"9.3.6",
"9.3.7",
"9.3.8",
"9.3.9",
"9.4.0",
"9.4.0RC1",
"9.4.0RC2",
"9.4.1",
"9.4.2",
"9.4.3",
"9.4.4",
"9.4.5",
"9.4.6",
"9.4.7",
"9.4.8",
"9.5.0",
"9.5.0RC1",
"9.5.0RC2"
]
}