GHSA-68q5-78xp-cwwclow3.3
Contao is vulnerable to cross-site scripting in templates
Impact
It is possible to inject code into the template output that will be executed in the browser in the front end and back end.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
contao/core-bundle Packagist
| Affected range | Recorded fix |
|---|---|
| From 4.0.0 before 4.13.57Ecosystem versions | 4.13.57 |
| From 5.0.0-RC1 before 5.3.42Ecosystem versions | 5.3.42 |
| From 5.4.0-RC1 before 5.6.5Ecosystem versions | 5.6.5 |
Version evidence: OSV · GHSA-68q5-78xp-cwwc
View original version evidence (435 explicit versions)
Original source description
Impact
It is possible to inject code into the template output that will be executed in the browser in the front end and back end.
Patches
Update to Contao 4.13.57, 5.3.42 or 5.6.5.
Workarounds
Do not use the affected templates or patch them manually.
Refsources
https://contao.org/en/security-advisories/cross-site-scripting-in-templates