GHSA-67cr-jmh8-4jpqlow2.4
Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability
The advisory, in context
Unauthenticated users can view a list of buckets the plugin has access to.
The DefaultController->actionLoadBucketData() endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see.
Users should update to version 2.2.1 of the plugin to mitigate the issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
craftcms/google-cloud Packagist
Ecosystem versions
From 2.0.0-beta.1 before 2.2.1
Fixed in 2.2.1
5 explicitly affected versions
2.0.0, 2.0.0-beta.1, 2.0.0-beta.2, 2.1.0, 2.2.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0-beta.1"
},
{
"fixed": "2.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.0-beta.1",
"2.0.0-beta.2",
"2.1.0",
"2.2.0"
]
}