GHSA-66mv-q8r2-hj8wmedium5.3
Drupal access bypass vulnerability
The advisory, in context
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/core Packagist
Ecosystem versions
From 7.0 before 7.57
Fixed in 7.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.57"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/drupal Packagist
Ecosystem versions
From 7.0 before 7.57
Fixed in 7.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.57"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6928
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6928.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6928.yaml
- https://github.com/drupal/core
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001