GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

All vulnerabilities
GHSA-66h8-3g48-6hx8critical9.8

Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context

Check your stack

The advisory, in context

Edge3 Worker RPC RCE on Airflow 2.

This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2.

The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.

If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.

If projects used Edge Provider in Airflow 3, you they are not affected.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 2.0.0

Fixed in 2.0.0

29 explicitly affected versions

1.0.0, 1.0.0rc1, 1.0.0rc2, 1.1.0, 1.1.0rc1, 1.1.1, 1.1.1rc1, 1.1.2, 1.1.2rc1, 1.1.2rc2, 1.1.3, 1.1.3rc1, 1.2.0, 1.2.0rc1, 1.3.0, 1.3.0rc1, 1.3.1, 1.3.1rc1, 1.4.0, 1.4.0rc1, 1.4.1, 1.4.1rc1, 1.4.1rc2, 1.5.0, 1.5.0rc1, 1.6.0, 1.6.0rc1, 1.6.0rc2, 2.0.0rc1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "2.0.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.0.0",
    "1.0.0rc1",
    "1.0.0rc2",
    "1.1.0",
    "1.1.0rc1",
    "1.1.1",
    "1.1.1rc1",
    "1.1.2",
    "1.1.2rc1",
    "1.1.2rc2",
    "1.1.3",
    "1.1.3rc1",
    "1.2.0",
    "1.2.0rc1",
    "1.3.0",
    "1.3.0rc1",
    "1.3.1",
    "1.3.1rc1",
    "1.4.0",
    "1.4.0rc1",
    "1.4.1",
    "1.4.1rc1",
    "1.4.1rc2",
    "1.5.0",
    "1.5.0rc1",
    "1.6.0",
    "1.6.0rc1",
    "1.6.0rc2",
    "2.0.0rc1"
  ]
}

References