UniSharp Laravel Filemanager Code Injection vulnerability
The advisory, in context
Versions of the package unisharp/laravel-filemanager before 2.9.1 are vulnerable to Remote Code Execution (RCE) through using a valid mimetype and inserting the . character after the php file extension. This allows the attacker to execute malicious code.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.9.1
Fixed in 2.9.1
71 explicitly affected versions
0.1.0, 0.2.0, 0.3.0, 0.3.1, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 1.0.0, 1.1.0, 1.1.0-alpha, 1.1.1, 1.2.0, 1.3.0-alpha, 1.4.0-alpha, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, v1.7-alpha, v1.7.0, v1.7.1, v1.7.2, v1.7.3, v1.7.4, v1.7.5, v1.7.6, v1.7.7, v1.8.0, v1.8.1, v1.8.2, v1.8.2-alpha, v1.8.2.1, v1.8.2.2, v1.8.3, v1.8.4, v1.8.5, v1.9.0, v1.9.1, v1.9.2, v2.0.0, v2.0.0-alpha, v2.0.0-alpha2, v2.0.0-alpha3, v2.0.0-alpha4, v2.0.0-alpha5, v2.0.0-alpha6, v2.0.0-alpha7, v2.0.0-alpha8, v2.0.1, v2.1.0, v2.2.0, v2.3.0, v2.4.0, v2.4.1, v2.5.0, v2.5.1, v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.7.0, v2.7.1, v2.8.0, v2.8.1, v2.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.9.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.2.0",
"0.3.0",
"0.3.1",
"0.5.0",
"0.5.1",
"0.5.2",
"0.5.3",
"1.0.0",
"1.1.0",
"1.1.0-alpha",
"1.1.1",
"1.2.0",
"1.3.0-alpha",
"1.4.0-alpha",
"1.5.0",
"1.5.1",
"1.5.2",
"1.6.0",
"1.6.1",
"1.6.2",
"1.6.3",
"1.6.4",
"v1.7-alpha",
"v1.7.0",
"v1.7.1",
"v1.7.2",
"v1.7.3",
"v1.7.4",
"v1.7.5",
"v1.7.6",
"v1.7.7",
"v1.8.0",
"v1.8.1",
"v1.8.2",
"v1.8.2-alpha",
"v1.8.2.1",
"v1.8.2.2",
"v1.8.3",
"v1.8.4",
"v1.8.5",
"v1.9.0",
"v1.9.1",
"v1.9.2",
"v2.0.0",
"v2.0.0-alpha",
"v2.0.0-alpha2",
"v2.0.0-alpha3",
"v2.0.0-alpha4",
"v2.0.0-alpha5",
"v2.0.0-alpha6",
"v2.0.0-alpha7",
"v2.0.0-alpha8",
"v2.0.1",
"v2.1.0",
"v2.2.0",
"v2.3.0",
"v2.4.0",
"v2.4.1",
"v2.5.0",
"v2.5.1",
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.7.0",
"v2.7.1",
"v2.8.0",
"v2.8.1",
"v2.9.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-21546
- https://github.com/UniSharp/laravel-filemanager/commit/8170760c0ae316d77b9363cd4c76ab68d3f63f0b
- https://gist.github.com/ImHades101/338a06816ef97262ba632af9c78b78ca
- https://github.com/UniSharp/laravel-filemanager
- https://security.snyk.io/vuln/SNYK-PHP-UNISHARPLARAVELFILEMANAGER-7210316