Plaintext Storage of Sensitive Information in Laravel Log Viewer before v0.13.0
The advisory, in context
rap2hpoutre Laravel Log Viewer before v0.13.0 relies on Base64 encoding for l, dl, and del requests, which makes it easier for remote attackers to bypass intended access restrictions, as demonstrated by reading arbitrary files via a dl request.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.13.0
Fixed in 0.13.0
45 explicitly affected versions
v0.1.0, v0.1.1, v0.1.10, v0.1.2, v0.1.3, v0.1.4, v0.1.5, v0.1.6, v0.1.7, v0.1.8, v0.1.9, v0.10.0, v0.10.1, v0.10.2, v0.10.3, v0.10.4, v0.11.0, v0.11.1, v0.11.2, v0.12.0, v0.2.0, v0.2.1, v0.2.2, v0.2.3, v0.2.4, v0.2.5, v0.2.6, v0.2.7, v0.2.8, v0.3.0, v0.4.0, v0.4.1, v0.4.2, v0.4.3, v0.5.0, v0.5.1, v0.5.2, v0.5.3, v0.6.0, v0.6.1, v0.7.0, v0.7.1, v0.8.0, v0.8.1, v0.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.13.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0",
"v0.1.1",
"v0.1.10",
"v0.1.2",
"v0.1.3",
"v0.1.4",
"v0.1.5",
"v0.1.6",
"v0.1.7",
"v0.1.8",
"v0.1.9",
"v0.10.0",
"v0.10.1",
"v0.10.2",
"v0.10.3",
"v0.10.4",
"v0.11.0",
"v0.11.1",
"v0.11.2",
"v0.12.0",
"v0.2.0",
"v0.2.1",
"v0.2.2",
"v0.2.3",
"v0.2.4",
"v0.2.5",
"v0.2.6",
"v0.2.7",
"v0.2.8",
"v0.3.0",
"v0.4.0",
"v0.4.1",
"v0.4.2",
"v0.4.3",
"v0.5.0",
"v0.5.1",
"v0.5.2",
"v0.5.3",
"v0.6.0",
"v0.6.1",
"v0.7.0",
"v0.7.1",
"v0.8.0",
"v0.8.1",
"v0.9.0"
]
}